• moderiert von:
  • OSS-Admin
Zum aktuellsten Beitrag
Zeichenkodierung/eGroupware
  • verfasst: 06.10.2005, 12:48
     
    Forenrang:
    Profi Profi
    registriert:
     Mai 2005
    Status:
    offline
    letzter Besuch:
    28.05.09
    Beiträge:
    20
    Wenn ich von zuhause aus die eGroupware aufrufe und mir die eingegangenen Mails ansehe, so werden Umlaute grundsätzlich falsch dargestellt. Ich nehme mal an, das liegt daran, dass die Mails in iso-8859-1 erstellt wurden und der OSS mit UTF-8 (?).
    Kriegt man das irgendwie hin, dass die Mails im Browser "vernünftig" erscheinen?
  • verfasst: 06.10.2005, 13:03
    Anonymous
    registriert:
     November 2003
    Status:
    offline
    letzter Besuch:
    05.02.09
    Beiträge:
    360
    Vielleicht mal die Kodierung im Browser umstellen?
  • verfasst: 06.10.2005, 22:09
       
    Lars
    Forenrang:
    Site Admin Site Admin
    registriert:
     November 2003
    Status:
    offline
    letzter Besuch:
    27.11.09
    Beiträge:
    526
    efellWenn ich von zuhause aus die eGroupware aufrufe und mir die eingegangenen Mails ansehe, so werden Umlaute grundsätzlich falsch dargestellt. Ich nehme mal an, das liegt daran, dass die Mails in iso-8859-1 erstellt wurden und der OSS mit UTF-8 (?).
    Kriegt man das irgendwie hin, dass die Mails im Browser "vernünftig" erscheinen?


    Hm. Noch nicht ausprobiert, aber evtl. hilft der Eintrag:
    AddDefaultCharset iso-8859-15

    in der Datei /etc/apache/httpd.conf.local (muss neu angelegt und in /etc/sysconfig/apache2 eingetragen werden). AnschlieÃ?end SuSEconfig und rcapache2 restart.

    Danach liefert der Apache alle Seiten, bei denen das Charset nicht ausdrücklich in der (HTML-)Datei steht, mit iso-8859-15 aus.
  • verfasst: 07.10.2005, 12:19
     
    Forenrang:
    Profi Profi
    registriert:
     Mai 2005
    Status:
    offline
    letzter Besuch:
    28.05.09
    Beiträge:
    20
    Hallo Lars,

    Danke für den Tipp, aber funktioniert hat's leider nicht.
    Die Zeichenkodierung im Mozilla steht auf iso-8859-15

    Gruss, Bert





    editiert von: efell, 07.10.2005, 12:23 Uhr
  • verfasst: 07.10.2005, 13:18
       
    Lars
    Forenrang:
    Site Admin Site Admin
    registriert:
     November 2003
    Status:
    offline
    letzter Besuch:
    27.11.09
    Beiträge:
    526
    Hm. Mir fällt gerade auf, dass du eGroupware sagtest (ja: meine Augen lassen nach... :)

    Evlt. könnte man also auch in der /etc/php.ini tricksen. Da muss ich aber erst nachsehen, ob das nicht evtl. Auswirkungen auf andere Sachen hat...

 Suchen:


 Umfrage

(Nur für angemeldete Benutzer)

Was wird hier am meisten vermisst?

[ Ergebnis | Umfragen ]

Stimmen: 621
Kommentare: 0

 Zitate

Brauchen Device-Driver einen Führerschein?

-- anonymous