• moderiert von:
  • Forenmoderatoren

gehe zu Seite: [-1] 1 - 2

Zum aktuellsten Beitrag
ubuntu (edubuntu) client am OSS2
  • verfasst: 14.12.2007, 09:44
     
    Forenrang:
    Profi Profi
    registriert:
     Mrz 2006
    Status:
    offline
    letzter Besuch:
    29.06.08
    Beiträge:
    80
    Die Anmeldung klappt jetzt! Hurra!. Ich habe die Aktualisierung auf die Version 7.10 unterdrückt. Ich habe Edubuntu (mit Gnome) aufgespielt
    Habe aber trotzdem noch ein Problem:

    An Frank:
    Wie hast du es gelöst, falls du dich mal lokal anmelden möchtest?. Das funktioniert nun nicht mehr. Die lokale Anmeldung benötige ich ja z.B, wenn ich neue Pakete einspielen will oder wenn ich mal einen Befehl als root (sudo..) ausführen will. Das ürsprüngliche Passwort (lokaler root oder auch das vom Adminstrator) funktioniert nicht mehr. Ich kann die Kiste ja nun nun nicht mal mehr runterfahren (von der Konsole)
  • verfasst: 17.12.2007, 10:26
     
    f.schoettler
    registriert:
     Februar 2005
    Status:
    offline
    letzter Besuch:
    26.04.12
    Beiträge:
    111
    Teetasse
    Wie hast du es gelöst, falls du dich mal lokal anmelden möchtest?.


    Schau mal in die "Benutzerverwaltung" dort wird u.A. Festgelegt wo das Heimatverzeichnis des Users liegt.
    den lokalen user - am besten vorher - von /home/"localuser" nach /"localuser" verschieben


    --
    gruss

    frank
  • verfasst: 17.12.2007, 10:30
     
    f.schoettler
    registriert:
     Februar 2005
    Status:
    offline
    letzter Besuch:
    26.04.12
    Beiträge:
    111
    tomHat es denn schon jemand für die Version 7.10 geschafft?

    Schöne Vorweihnachtszeit
    Thomas


    nicht direkt icon_wink

    update von 7.04 auf 7.10 => danach gab es Probleme mit dem NFS mount
    => NFS pakete (wieder) aufspielen => reboot => ok




    --
    gruss

    frank
  • verfasst: 17.12.2007, 18:26
     
    Forenrang:
    Profi Profi
    registriert:
     Mrz 2006
    Status:
    offline
    letzter Besuch:
    29.06.08
    Beiträge:
    80
    Zitat
    Schau mal in die "Benutzerverwaltung" dort wird u.A. Festgelegt wo das Heimatverzeichnis des Users liegt.
    den lokalen user - am besten vorher - von /home/"localuser" nach /"localuser" verschieben


    Mist, dann muss ich ja wieder von vorn anfangen!
    Aber ich glaube nicht, dass es nur am fehlenden Homeverzeichnis lag. Dann wäre ja wenigstens eine Anmeldung möglich was eine Fehlermeldung wegen der fehlenden Homeverzeuchnissses zur Folge hätte.
  • verfasst: 18.12.2007, 08:36
     
    f.schoettler
    registriert:
     Februar 2005
    Status:
    offline
    letzter Besuch:
    26.04.12
    Beiträge:
    111
    Teetasse
    Aber ich glaube nicht, dass es nur am fehlenden Homeverzeichnis lag. Dann wäre ja wenigstens eine Anmeldung möglich was eine Fehlermeldung wegen der fehlenden Homeverzeuchnissses zur Folge hätte.


    Hast du die Einträge der /etc/pam.d/ files ( common-password, common-auth, common session ) um "use_first_pass" erweitert ?
    Hatte anfangs auch die Anleitung "zu schnell gelesen" icon_rolleyes - soll hei?en nur die .... sufficient pam_ldap.so Einträge hinzugefügt
    und dabei übersehen das die .... required pam_unix.so Zeile erweitert werden muß .....

    Zitat/etc/pam.d/common-auth

    auth sufficient pam_ldap.so
    auth required pam_unix.so use_first_pass nullok_secure

    auth ist für die Sicherheit zuständig, ob der User, der er vorgibt zu sein auch wirklich dieser ist und somit ein Passwort verlangt.

    /etc/pam.d/common-account

    account sufficient pam_ldap.so
    account required pam_unix.so use_first_pass

    account prüft die Berechtigung, ob ein User den Dienst benutzen darf, oder ob vielleicht sein Passwort abgelaufen ist.

    /etc/pam.d/common-password

    password sufficient pam_ldap.so
    password required pam_unix.so use_first_pass nullok obscure min=4 max=8 md5

    password spezifiziert, wie ein Passwort gewechselt wird und wie dieses zusammengesetzt werden muss.

    /etc/pam.d/common-session

    session required pam_unix.so
    session optional pam_foreground.so

    session übernimmt alle wichtigen Prioritätsaufgaben und regelt die Prozesse wie das zur Verfügung stellen des Heimatverzeichnisses.




    --
    gruss

    frank
  • verfasst: 19.12.2007, 07:54
     
    f.schoettler
    registriert:
     Februar 2005
    Status:
    offline
    letzter Besuch:
    26.04.12
    Beiträge:
    111
    tom
    Hat es denn schon jemand für die Version 7.10 geschafft?
    Thomas


    try this
    http://ubuntufo...php?t=597056

    frohes fest !


    --
    gruss

    frank
  • verfasst: 30.12.2007, 15:16
     
    Forenrang:
    Fachlich versiert Fachlich versiert
    registriert:
     Dezember 2006
    Status:
    offline
    letzter Besuch:
    28.01.09
    Beiträge:
    10
    Zitat
    update von 7.04 auf 7.10 => danach gab es Probleme mit dem NFS mount
    => NFS pakete (wieder) aufspielen => reboot => ok


    Das habe ich gerade auch mal versucht. Was muss ich denn bei der Frage angeben, ob debconf die LDAP-Konfiguration aktualisieren soll? Gibt es sonst noch etwas beim Upgrade zu beachten?

    Guten Rutsch
    Thomas
  • verfasst: 19.02.2008, 07:26
     
    f.schoettler
    registriert:
     Februar 2005
    Status:
    offline
    letzter Besuch:
    26.04.12
    Beiträge:
    111
    ZitatHat es denn schon jemand für die Version 7.10 geschafft?


    Hallo zusammen,

    eine Anleitung 7.10 Active Directory Client Authentifikation
    bekommst du hier http://wiki.ubu...entifikation

    wiki.ubuntuusers.de/Active_Directory_Client_Authentifikation






    --
    gruss

    frank
  • verfasst: 10.02.2009, 11:30
     
    Forenrang:
    Normaler Benutzer Normaler Benutzer
    registriert:
     Februar 2009
    Status:
    offline
    letzter Besuch:
    01.04.09
    Beiträge:
    7
    Hallo zusammen,

    ich bin nach der Anleitung http://wiki.ubuntuusers.de/LDAP_Client_Authentifizierung vorgegangen. Als es dann ans Testen der Konfiguration ging mit "getent passwd" wurden nur die lokalen Benutzer aufgelistet.
    Mit "ldapsearch -x -z 1" konnte ich aber auf den Ldap-Server zugreifen. Mit einem Neustart konnte ich mich auch nur mit dem lokalen Benutzer anmelden.

    Was habe ich vergessen oder falsch gemacht ? icon_confused

    Ich verwende den OSS 2.6.1 und als Client Kubuntu 8.04


    Grüße

    Oliver
  • verfasst: 12.02.2009, 06:39
     
    Forenrang:
    Normaler Benutzer Normaler Benutzer
    registriert:
     Februar 2009
    Status:
    offline
    letzter Besuch:
    01.04.09
    Beiträge:
    7
    Guten Morgen,

    das Problem hat sich erledigt. In der ldap.conf stand noch "ssl yes" wie es in der Anleitung zum OSS steht. Nachdem ich es auf "no" gesetzt habe hat es funktioniert. Muss mich jetzt wohl noch um die SSLkonfiguration kümmern icon_frown


    Grüße

    Oliver
  • verfasst: 18.06.2010, 09:59
     
    f.schoettler
    registriert:
     Februar 2005
    Status:
    offline
    letzter Besuch:
    26.04.12
    Beiträge:
    111
    Ubuntu als Client am OSS

    1.) LDAP Anbindung
    => Anleitung auf http://wiki.ubu...thentication

    habe mir alalog zur Anleitung ein kleines Script "gebaut":

    Code
    1. # script Ubuntu AT OSS zur Anleitung von
    2. #
    3. #http://wiki.ubuntuusers.de/OpenLDAP
    4. #
    5. # 18-6-2010 by luebby
    6.  
    7. # pakete  holen und installieren
    8. sudo apt-get --yes install libnss-ldapd
    9. sudo apt-get --yes install nslcd
    10. sudo apt-get --yes install ldap-auth-client
    11. sudo apt-get --yes install ldap-auth-config
    12.  
    13. # configure
    14. sudo dpkg-reconfigure ldap-auth-config
    15. sudo auth-client-config -t nss -p lac_ldap
    16. sudo pam-auth-update
    2.) NFS-Client in der /etc/fstab des Buntus statt des sonst ueblichen "defaults" "rw" eintragen
    Code
    1. IP-ADRESSE-OSS:/home /home nfs rw 0 0


    gestestet mit ubuntu 10.04 und OSS3 18-6-2010



    --
    gruss

    frank
  • verfasst: 26.04.2012, 06:44
     
    f.schoettler
    registriert:
     Februar 2005
    Status:
    offline
    letzter Besuch:
    26.04.12
    Beiträge:
    111
    Hallo zusammen,

    hier UNGETESTET von [URL=http://repo.openschoolserver.net/ubuntu/]]

    ==============upload 05-Apr-2012 06:31=================
    Installation von oss-ccd

    Zwei zusätzlichen Pakete müssen installiert
    werden:
    * xlockmore
    * libio-socket-ssl-perl

    Tarball auspacken:
    tar xjf oss-ccd.tar.bz2

    oss-ccd installieren:
    cd oss-ccd
    make install

    oss-ccd aktivieren:
    insserv -f oss-ccd

    ==============upload 05-Apr-2012 06:31=================

    --
    gruss

    frank

gehe zu Seite: [-1] 1 - 2


 Suchen:


 Umfrage

(Nur für angemeldete Benutzer)

Was wird hier am meisten vermisst?

[ Ergebnis | Umfragen ]

Stimmen: 621
Kommentare: 0

 Zitate

Wettervorher-Sage [:-)]

-- anonymous